What’s Vulnerable › Vulnerabilities
CVE-2018-1000216
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-415
Description
Dave Gamble cJSON version 1.7.2 and earlier contains a CWE-415: Double Free vulnerability in cJSON library that can result in Possible crash or RCE. This attack appear to be exploitable via Attacker must be able to force victim to print JSON data, depending on how cJSON library is used this could be either local or over a network. This vulnerability appears to have been fixed in 1.7.3.
Affected products
- DaveGamble cJSON: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: DaveGamble cJSON 1.7.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1000216 or the next vulnerability affects your stack