What’s Vulnerable › Vulnerabilities
CVE-2018-1000217
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-416
Description
Dave Gamble cJSON version 1.7.3 and earlier contains a CWE-416: Use After Free vulnerability in cJSON library that can result in Possible crash, corruption of data or even RCE. This attack appear to be exploitable via Depends on how application uses cJSON library. If application provides network interface then can be exploited over a network, otherwise just local.. This vulnerability appears to have been fixed in 1.7.4.
Affected products
- DaveGamble cJSON: before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: DaveGamble cJSON 1.7.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1000217 or the next vulnerability affects your stack