What’s Vulnerable › Vulnerabilities
CVE-2018-1000221
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-119
Description
pkgconf version 1.5.0 to 1.5.2 contains a Buffer Overflow vulnerability in dequote() that can result in dequote() function returns 1-byte allocation if initial length is 0, leading to buffer overflow. This attack appear to be exploitable via specially crafted .pc file. This vulnerability appears to have been fixed in 1.5.3.
Affected products
- Pkgconf: from 1.5.0 through 1.5.2
References
- https://git.dereferenced.org/pkgconf/pkgconf/pulls/3
- https://git.dereferenced.org/pkgconf/pkgconf/pulls/3
Get alerted when CVE-2018-1000221 or the next vulnerability affects your stack