What’s Vulnerable › Vulnerabilities
CVE-2018-1000300
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-24 · updated 2026-06-17
- Weakness: CWE-787
Description
curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- curl: from 7.54.1 through 7.59.0
References
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
- http://www.securityfocus.com/bid/104207
- http://www.securitytracker.com/id/1040933
- https://curl.haxx.se/docs/adv_2018-82c2.html
- https://security.gentoo.org/glsa/201806-05
- https://usn.ubuntu.com/3648-1/
- https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
- http://www.securityfocus.com/bid/104207
- http://www.securitytracker.com/id/1040933
Get alerted when CVE-2018-1000300 or the next vulnerability affects your stack