What’s Vulnerable › Vulnerabilities
CVE-2018-1000400
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-18 · updated 2026-06-17
- Weakness: CWE-269
Description
Kubernetes CRI-O version prior to 1.9 contains a Privilege Context Switching Error (CWE-270) vulnerability in the handling of ambient capabilities that can result in containers running with elevated privileges, allowing users abilities they should not have. This attack appears to be exploitable via container execution. This vulnerability appears to have been fixed in 1.9.
Affected products
- cri-o: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: cri-o 1.9.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104262
- https://github.com/kubernetes-incubator/cri-o/pull/1558/files
- http://www.securityfocus.com/bid/104262
- https://github.com/kubernetes-incubator/cri-o/pull/1558/files
Get alerted when CVE-2018-1000400 or the next vulnerability affects your stack