What’s Vulnerable › Vulnerabilities
CVE-2018-1000404
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-09 · updated 2026-06-17
- Weakness: CWE-522
Description
Jenkins project Jenkins AWS CodeBuild Plugin version 0.26 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSClientFactory.java, CodeBuilder.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.27 and later.
Affected products
- Jenkins Aws Codebuild: through 0.26
References
- https://jenkins.io/security/advisory/2018-06-25/#SECURITY-834
- https://jenkins.io/security/advisory/2018-06-25/#SECURITY-834
Get alerted when CVE-2018-1000404 or the next vulnerability affects your stack