What’s Vulnerable › Vulnerabilities
CVE-2018-1000517
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 32.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-26 · updated 2026-06-17
- Weakness: CWE-120
Description
BusyBox project BusyBox wget version prior to commit 8e2174e9bd836e53c8b9c6e00d1bc6e2a718686e contains a Buffer Overflow vulnerability in Busybox wget that can result in heap buffer overflow. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in after commit 8e2174e9bd836e53c8b9c6e00d1bc6e2a718686e.
Affected products
- busybox: before 1.29.0 — fixed in 1.29.0
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: busybox 1.29.0. Check the vendor advisory for mitigations.
References
- https://git.busybox.net/busybox/commit/?id=8e2174e9bd836e53c8b9c6e00d1bc6e2a718686e
- https://lists.debian.org/debian-lts-announce/2018/07/msg00037.html
- https://lists.debian.org/debian-lts-announce/2021/02/msg00020.html
- https://usn.ubuntu.com/3935-1/
- https://git.busybox.net/busybox/commit/?id=8e2174e9bd836e53c8b9c6e00d1bc6e2a718686e
- https://lists.debian.org/debian-lts-announce/2018/07/msg00037.html
- https://lists.debian.org/debian-lts-announce/2021/02/msg00020.html
- https://usn.ubuntu.com/3935-1/
Get alerted when CVE-2018-1000517 or the next vulnerability affects your stack