What’s Vulnerable › Vulnerabilities
CVE-2018-1000524
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-26 · updated 2026-06-17
- Weakness: CWE-190
Description
miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of service. This attack appear to be exploitable via the victim must load a specially-crafted map which calls SetLayerSize in its entry script. This vulnerability appears to have been fixed in 5.0.3, 5.1.5, 5.2.10 and later.
Affected products
- Spheredev Minisphere: through 5.2.9
References
- https://github.com/fatcerberus/minisphere/commit/252c1ca184cb38e1acb917aa0e451c5f08519996
- https://github.com/fatcerberus/minisphere/pull/268
- https://github.com/fatcerberus/minisphere/commit/252c1ca184cb38e1acb917aa0e451c5f08519996
- https://github.com/fatcerberus/minisphere/pull/268
Get alerted when CVE-2018-1000524 or the next vulnerability affects your stack