What’s Vulnerable › Vulnerabilities
CVE-2018-1000620
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-09 · updated 2026-06-17
- Weakness: CWE-331
Description
Eran Hammer cryptiles version 4.1.1 earlier contains a CWE-331: Insufficient Entropy vulnerability in randomDigits() method that can result in An attacker is more likely to be able to brute force something that was supposed to be random.. This attack appear to be exploitable via Depends upon the calling application.. This vulnerability appears to have been fixed in 4.1.2.
Affected products
- Cryptiles Project Cryptiles: before 3.1.3; from 4.1.0 before 4.1.2 — fixed in 3.1.3, 4.1.2
How to fix
Upgrade to a fixed version: Cryptiles Project Cryptiles 3.1.3, 4.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/hapijs/cryptiles/issues/34
- https://github.com/hapijs/cryptiles/issues/35
- https://github.com/hapijs/cryptiles/issues/34
- https://github.com/hapijs/cryptiles/issues/35
Get alerted when CVE-2018-1000620 or the next vulnerability affects your stack