What’s Vulnerable › Vulnerabilities
CVE-2018-1000622
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-09 · updated 2026-06-17
- Weakness: CWE-427
Description
The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.
Affected products
- rust-lang rust: from 0.8 through 1.27.0
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00031.html
- https://groups.google.com/forum/#%21topic/rustlang-security-announcements/4ybxYLTtXuM
- https://security.gentoo.org/glsa/201812-11
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00031.html
- https://groups.google.com/forum/#%21topic/rustlang-security-announcements/4ybxYLTtXuM
- https://security.gentoo.org/glsa/201812-11
Get alerted when CVE-2018-1000622 or the next vulnerability affects your stack