What’s Vulnerable › Vulnerabilities
CVE-2018-1000656
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-20
Description
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.
Affected products
- NetApp Active Iq: all versions
- NetApp Hyper Converged Infrastructure: all versions
- NetApp Ontap Select Deploy Utility: all versions
- pallets flask: before 0.12.3 — fixed in 0.12.3
How to fix
Upgrade to a fixed version: pallets flask 0.12.3. Check the vendor advisory for mitigations.
References
- https://github.com/pallets/flask/pull/2691
- https://github.com/pallets/flask/releases/tag/0.12.3
- https://lists.debian.org/debian-lts-announce/2019/08/msg00025.html
- https://security.netapp.com/advisory/ntap-20190221-0001/
- https://usn.ubuntu.com/4378-1/
- https://github.com/pallets/flask/pull/2691
- https://github.com/pallets/flask/releases/tag/0.12.3
- https://lists.debian.org/debian-lts-announce/2019/08/msg00025.html
- https://security.netapp.com/advisory/ntap-20190221-0001/
- https://usn.ubuntu.com/4378-1/
Get alerted when CVE-2018-1000656 or the next vulnerability affects your stack