What’s Vulnerable › Vulnerabilities
CVE-2018-1000657
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-119
Description
Rust Programming Language Rust standard library version Commit bfa0e1f58acf1c28d500c34ed258f09ae021893e and later; stable release 1.3.0 and later contains a Buffer Overflow vulnerability in std::collections::vec_deque::VecDeque::reserve() function that can result in Arbitrary code execution, but no proof-of-concept exploit is currently published.. This vulnerability appears to have been fixed in after commit fdfafb510b1a38f727e920dccbeeb638d39a8e60; stable release 1.22.0 and later.
Affected products
- rust-lang rust: from 1.3.0 before 1.22.0 — fixed in 1.22.0
How to fix
Upgrade to a fixed version: rust-lang rust 1.22.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105188
- https://github.com/rust-lang/rust/commit/f71b37bc28326e272a37b938e835d4f99113eec2
- https://github.com/rust-lang/rust/issues/44800
- http://www.securityfocus.com/bid/105188
- https://github.com/rust-lang/rust/commit/f71b37bc28326e272a37b938e835d4f99113eec2
- https://github.com/rust-lang/rust/issues/44800
Get alerted when CVE-2018-1000657 or the next vulnerability affects your stack