What’s Vulnerable › Vulnerabilities
CVE-2018-1000807
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-08 · updated 2026-06-17
- Weakness: CWE-416
Description
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
Affected products
- Canonical Ubuntu Linux: 16.04
- pyca pyopenssl: before 17.5.0 — fixed in 17.5.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- OpenStack: 13
How to fix
Upgrade to a fixed version: pyca pyopenssl 17.5.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.html
- https://access.redhat.com/errata/RHSA-2019:0085
- https://github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509
- https://github.com/pyca/pyopenssl/pull/723
- https://usn.ubuntu.com/3813-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.html
- https://access.redhat.com/errata/RHSA-2019:0085
- https://github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509
- https://github.com/pyca/pyopenssl/pull/723
- https://usn.ubuntu.com/3813-1/
Get alerted when CVE-2018-1000807 or the next vulnerability affects your stack