What’s Vulnerable › Vulnerabilities
CVE-2018-1000808
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-08 · updated 2026-06-17
- Weakness: CWE-404
Description
Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.
Affected products
- Canonical Ubuntu Linux: 16.04
- Pyopenssl Project Pyopenssl: before 17.5.0 — fixed in 17.5.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- Red Hat, Inc. Gluster Storage for RHEL 6: 3.0
- OpenStack: 13
How to fix
Upgrade to a fixed version: Pyopenssl Project Pyopenssl 17.5.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.html
- https://access.redhat.com/errata/RHSA-2019:0085
- https://github.com/pyca/pyopenssl/pull/723
- https://usn.ubuntu.com/3813-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.html
- https://access.redhat.com/errata/RHSA-2019:0085
- https://github.com/pyca/pyopenssl/pull/723
- https://usn.ubuntu.com/3813-1/
Get alerted when CVE-2018-1000808 or the next vulnerability affects your stack