What’s Vulnerable › Vulnerabilities
CVE-2018-1000817
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-20 · updated 2026-06-17
- Weakness: CWE-22
Description
Asset Pipeline Grails Plugin Asset-pipeline plugin version Prior to 2.14.1.1, 2.15.1 and 3.0.6 contains a Incorrect Access Control vulnerability in Applications deployed in Jetty that can result in Download .class files and any arbitrary file. This attack appear to be exploitable via Specially crafted GET request containing directory traversal from assets-pipeline context. This vulnerability appears to have been fixed in 2.14.1.1 (for Grails 2.x), 2.15.1 (for Grails 3 and Java 7) and 3.0.6 (for Grails 3 and Java 8).
Affected products
- Asset Pipeline Project Asset-Pipeline: before 2.14.1.1; from 2.14.1.1 (excl.) before 2.15.1; from 2.15.1 (excl.) before 3.0.6 — fixed in 2.14.1.1, 2.15.1, 3.0.6
How to fix
Upgrade to a fixed version: Asset Pipeline Project Asset-Pipeline 2.14.1.1, 2.15.1, 3.0.6. Check the vendor advisory for mitigations.
References
- http://grailsblog.objectcomputing.com/posts/2018/09/23/security-vulnerability-in-asset-pipeline-and-jetty.html
- https://github.com/grails/grails-core/issues/11068
- http://grailsblog.objectcomputing.com/posts/2018/09/23/security-vulnerability-in-asset-pipeline-and-jetty.html
- https://github.com/grails/grails-core/issues/11068
Get alerted when CVE-2018-1000817 or the next vulnerability affects your stack