What’s Vulnerable › Vulnerabilities
CVE-2018-1000823
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-20 · updated 2026-06-17
- Weakness: CWE-611
Description
exist version <= 5.0.0-RC4 contains a XML External Entity (XXE) vulnerability in XML Parser for REST Server that can result in Disclosure of confidential data, denial of service, SSRF, port scanning.
Affected products
- Exist-Db Exist: before 5.0.0; 5.0.0-rc1, 5.0.0-rc2, 5.0.0-rc3, 5.0.0-rc4 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Exist-Db Exist 5.0.0. Check the vendor advisory for mitigations.
References
- https://0dd.zone/2018/10/27/exist-XXE/
- https://github.com/eXist-db/exist/issues/2180
- https://0dd.zone/2018/10/27/exist-XXE/
- https://github.com/eXist-db/exist/issues/2180
Get alerted when CVE-2018-1000823 or the next vulnerability affects your stack