What’s Vulnerable › Vulnerabilities
CVE-2018-1000851
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-20 · updated 2026-06-17
- Weakness: CWE-522
Description
Copay Bitcoin Wallet version 5.01 to 5.1.0 included. contains a Other/Unknown vulnerability in wallet private key storage that can result in Users' private key can be compromised. . This attack appear to be exploitable via Affected version run the malicious code at startup . This vulnerability appears to have been fixed in 5.2.0 and later .
Affected products
- Copay Bitcoin Wallet: from 5.0.1 through 5.1.0
References
- https://arstechnica.com/information-technology/2018/11/hacker-backdoors-widely-used-open-source-software-to-steal-bitcoin/
- https://blog.bitpay.com/npm-package-vulnerability-copay/
- https://github.com/bitpay/copay/issues/9346
- https://github.com/dominictarr/event-stream/issues/116
- https://arstechnica.com/information-technology/2018/11/hacker-backdoors-widely-used-open-source-software-to-steal-bitcoin/
- https://blog.bitpay.com/npm-package-vulnerability-copay/
- https://github.com/bitpay/copay/issues/9346
- https://github.com/dominictarr/event-stream/issues/116
Get alerted when CVE-2018-1000851 or the next vulnerability affects your stack