What’s Vulnerable › Vulnerabilities
CVE-2018-1000872
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-20 · updated 2026-06-17
- Weakness: CWE-400
Description
OpenKMIP PyKMIP version All versions before 0.8.0 contains a CWE 399: Resource Management Errors (similar issue to CVE-2015-5262) vulnerability in PyKMIP server that can result in DOS: the server can be made unavailable by one or more clients opening all of the available sockets. This attack appear to be exploitable via A client or clients open sockets with the server and then never close them. This vulnerability appears to have been fixed in 0.8.0.
Affected products
- Pykmip Project Pykmip: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: Pykmip Project Pykmip 0.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1000872 or the next vulnerability affects your stack