What’s Vulnerable › Vulnerabilities
CVE-2018-10017
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-11 · updated 2026-06-17
- Weakness: CWE-125
Description
soundlib/Snd_fx.cpp in OpenMPT before 1.27.07.00 and libopenmpt before 0.3.8 allows remote attackers to cause a denial of service (out-of-bounds read) via an IT or MO3 file with many nested pattern loops.
Affected products
- Openmpt Libopenmpt: before 0.3.8 — fixed in 0.3.8
- Openmpt: before 1.27.07.00 — fixed in 1.27.07.00
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.3.8; Openmpt 1.27.07.00. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMPT/openmpt/commit/7ebf02af2e90f03e0dbd0e18b8b3164f372fb97c
- https://lib.openmpt.org/libopenmpt/2018/04/08/security-updates-0.3.8-0.2-beta31-0.2.7561-beta20.5-p8-0.2.7386-beta20.3-p11/
- https://openmpt.org/openmpt-1-27-07-00-released
- https://github.com/OpenMPT/openmpt/commit/7ebf02af2e90f03e0dbd0e18b8b3164f372fb97c
- https://lib.openmpt.org/libopenmpt/2018/04/08/security-updates-0.3.8-0.2-beta31-0.2.7561-beta20.5-p8-0.2.7386-beta20.3-p11/
- https://openmpt.org/openmpt-1-27-07-00-released
Get alerted when CVE-2018-10017 or the next vulnerability affects your stack