What’s Vulnerable › Vulnerabilities
CVE-2018-10021
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-11 · updated 2026-06-17
Description
drivers/scsi/libsas/sas_scsi_host.c in the Linux kernel before 4.16 allows local users to cause a denial of service (ata qc leak) by triggering certain failure conditions. NOTE: a third party disputes the relevance of this report because the failure can only occur for physically proximate attackers who unplug SAS Host Bus Adapter cables
Affected products
- Linux kernel: before 4.16 — fixed in 4.16
How to fix
Upgrade to a fixed version: Linux kernel 4.16. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=318aaf34f1179b39fa9c30fa0f3288b645beee39
- https://bugzilla.suse.com/show_bug.cgi?id=1089281
- https://github.com/torvalds/linux/commit/318aaf34f1179b39fa9c30fa0f3288b645beee39
- https://lists.debian.org/debian-lts-announce/2018/07/msg00020.html
- https://usn.ubuntu.com/3678-1/
- https://usn.ubuntu.com/3678-2/
- https://usn.ubuntu.com/3678-3/
- https://usn.ubuntu.com/3678-4/
- https://usn.ubuntu.com/3696-1/
- https://usn.ubuntu.com/3696-2/
- https://usn.ubuntu.com/3754-1/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=318aaf34f1179b39fa9c30fa0f3288b645beee39
Get alerted when CVE-2018-10021 or the next vulnerability affects your stack