What’s Vulnerable › Vulnerabilities
CVE-2018-1002104
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-14 · updated 2026-06-17
- Weakness: CWE-215
Description
Versions < 1.5 of the Kubernetes ingress default backend, which handles invalid ingress traffic, exposed prometheus metrics publicly.
Affected products
- Kubernetes Nginx Ingress Controller: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Kubernetes Nginx Ingress Controller 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/kubernetes/ingress-nginx/pull/3125
- https://github.com/kubernetes/ingress-nginx/pull/3125
Get alerted when CVE-2018-1002104 or the next vulnerability affects your stack