What’s Vulnerable › Vulnerabilities
CVE-2018-1002200
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-25 · updated 2026-06-17
- Weakness: CWE-22
Description
plexus-archiver before 3.6.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in an archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Affected products
- codehaus-plexus plexus-archiver: before 3.6.0 — fixed in 3.6.0
- Debian Linux: 8.0, 9.0
- Red Hat Enterprise Linux: 7.5
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: codehaus-plexus plexus-archiver 3.6.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:1836
- https://access.redhat.com/errata/RHSA-2018:1837
- https://github.com/codehaus-plexus/plexus-archiver/commit/f8f4233508193b70df33759ae9dc6154d69c2ea8
- https://github.com/codehaus-plexus/plexus-archiver/pull/87
- https://github.com/snyk/zip-slip-vulnerability
- https://snyk.io/research/zip-slip-vulnerability
- https://snyk.io/vuln/SNYK-JAVA-ORGCODEHAUSPLEXUS-31680
- https://www.debian.org/security/2018/dsa-4227
- https://access.redhat.com/errata/RHSA-2018:1836
- https://access.redhat.com/errata/RHSA-2018:1837
- https://github.com/codehaus-plexus/plexus-archiver/commit/f8f4233508193b70df33759ae9dc6154d69c2ea8
- https://github.com/codehaus-plexus/plexus-archiver/pull/87
Get alerted when CVE-2018-1002200 or the next vulnerability affects your stack