What’s Vulnerable › Vulnerabilities
CVE-2018-1002203
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-25 · updated 2026-06-17
- Weakness: CWE-22
Description
unzipper npm library before 0.8.13 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Affected products
- node.js unzipper: before 0.8.13 — fixed in 0.8.13
How to fix
Upgrade to a fixed version: node.js unzipper 0.8.13. Check the vendor advisory for mitigations.
References
- https://github.com/ZJONSSON/node-unzipper/commit/2220ddd5b58f6252069a4f99f9475441ad0b50cd
- https://github.com/ZJONSSON/node-unzipper/pull/59
- https://github.com/snyk/zip-slip-vulnerability
- https://snyk.io/research/zip-slip-vulnerability
- https://snyk.io/vuln/npm:unzipper:20180415
- https://github.com/ZJONSSON/node-unzipper/commit/2220ddd5b58f6252069a4f99f9475441ad0b50cd
- https://github.com/ZJONSSON/node-unzipper/pull/59
- https://github.com/snyk/zip-slip-vulnerability
- https://snyk.io/research/zip-slip-vulnerability
- https://snyk.io/vuln/npm:unzipper:20180415
Get alerted when CVE-2018-1002203 or the next vulnerability affects your stack