What’s Vulnerable › Vulnerabilities
CVE-2018-1002204
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-25 · updated 2026-06-17
- Weakness: CWE-22
Description
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Affected products
- node.js adm-zip: before 0.4.9 — fixed in 0.4.9
How to fix
Upgrade to a fixed version: node.js adm-zip 0.4.9. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107001
- https://github.com/cthackers/adm-zip/commit/62f64004fefb894c523a7143e8a88ebe6c84df25
- https://github.com/cthackers/adm-zip/pull/212
- https://github.com/snyk/zip-slip-vulnerability
- https://snyk.io/research/zip-slip-vulnerability
- https://snyk.io/vuln/npm:adm-zip:20180415
- http://www.securityfocus.com/bid/107001
- https://github.com/cthackers/adm-zip/commit/62f64004fefb894c523a7143e8a88ebe6c84df25
- https://github.com/cthackers/adm-zip/pull/212
- https://github.com/snyk/zip-slip-vulnerability
- https://snyk.io/research/zip-slip-vulnerability
- https://snyk.io/vuln/npm:adm-zip:20180415
Get alerted when CVE-2018-1002204 or the next vulnerability affects your stack