What’s Vulnerable › Vulnerabilities
CVE-2018-1002209
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-25 · updated 2026-06-17
- Weakness: CWE-22
Description
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Affected products
- quazip: before 0.7.6 — fixed in 0.7.6
How to fix
Upgrade to a fixed version: quazip 0.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/snyk/zip-slip-vulnerability
- https://github.com/stachenov/quazip/blob/0.7.6/NEWS.txt
- https://github.com/stachenov/quazip/commit/5d2fc16a1976e5bf78d2927b012f67a2ae047a98
- https://snyk.io/research/zip-slip-vulnerability
- https://github.com/snyk/zip-slip-vulnerability
- https://github.com/stachenov/quazip/blob/0.7.6/NEWS.txt
- https://github.com/stachenov/quazip/commit/5d2fc16a1976e5bf78d2927b012f67a2ae047a98
- https://snyk.io/research/zip-slip-vulnerability
Get alerted when CVE-2018-1002209 or the next vulnerability affects your stack