What’s Vulnerable › Vulnerabilities
CVE-2018-10055
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-24 · updated 2026-06-17
- Weakness: CWE-119
Description
Invalid memory access and/or a heap buffer overflow in the TensorFlow XLA compiler in Google TensorFlow before 1.7.1 could cause a crash or read from other parts of process memory via a crafted configuration file.
Affected products
- tensorflow: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: tensorflow 1.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-006.md
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-006.md
Get alerted when CVE-2018-10055 or the next vulnerability affects your stack