What’s Vulnerable › Vulnerabilities
CVE-2018-10101
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-16 · updated 2026-06-17
- Weakness: CWE-601
Description
Before WordPress 4.9.5, the URL validator assumed URLs with the hostname localhost were on the same host as the WordPress server.
Affected products
- Debian Linux: 8.0, 9.0
- WordPress: before 4.9.5 — fixed in 4.9.5
How to fix
Upgrade to a fixed version: WordPress 4.9.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104350
- http://www.securitytracker.com/id/1040836
- https://codex.wordpress.org/Version_4.9.5
- https://core.trac.wordpress.org/changeset/42894
- https://github.com/WordPress/WordPress/commit/804363859602d4050d9a38a21f5a65d9aec18216
- https://wordpress.org/news/2018/04/wordpress-4-9-5-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9053
- https://www.debian.org/security/2018/dsa-4193
- http://www.securityfocus.com/bid/104350
- http://www.securitytracker.com/id/1040836
- https://codex.wordpress.org/Version_4.9.5
- https://core.trac.wordpress.org/changeset/42894
Get alerted when CVE-2018-10101 or the next vulnerability affects your stack