What’s Vulnerable › Vulnerabilities
CVE-2018-10102
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.
Affected products
- Debian Linux: 8.0, 9.0
- WordPress: before 4.9.5 — fixed in 4.9.5
How to fix
Upgrade to a fixed version: WordPress 4.9.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103775
- http://www.securitytracker.com/id/1040836
- https://codex.wordpress.org/Version_4.9.5
- https://core.trac.wordpress.org/changeset/42893
- https://github.com/WordPress/WordPress/commit/31a4369366d6b8ce30045d4c838de2412c77850d
- https://lists.debian.org/debian-lts-announce/2018/04/msg00031.html
- https://wordpress.org/news/2018/04/wordpress-4-9-5-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/9055
- https://www.debian.org/security/2018/dsa-4193
- http://www.securityfocus.com/bid/103775
- http://www.securitytracker.com/id/1040836
- https://codex.wordpress.org/Version_4.9.5
Get alerted when CVE-2018-10102 or the next vulnerability affects your stack