What’s Vulnerable › Vulnerabilities
CVE-2018-10119
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-16 · updated 2026-06-17
- Weakness: CWE-416
Description
sot/source/sdstor/stgstrms.cxx in LibreOffice before 5.4.5.1 and 6.x before 6.0.1.1 uses an incorrect integer data type in the StgSmallStrm class, which allows remote attackers to cause a denial of service (use-after-free with write access) or possibly have unspecified other impact via a crafted document that uses the structured storage ole2 wrapper file format.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Debian Linux: 7.0, 8.0, 9.0
- The Document Foundation LibreOffice: before 5.4.5.1; from 6.0.0 before 6.0.1.1 — fixed in 5.4.5.1, 6.0.1.1
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 5.4.5.1, 6.0.1.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:3054
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=5747
- https://gerrit.libreoffice.org/#/c/48751/
- https://gerrit.libreoffice.org/#/c/48756/
- https://gerrit.libreoffice.org/#/c/48757/
- https://gerrit.libreoffice.org/#/c/48758/
- https://gerrit.libreoffice.org/gitweb?p=core.git%3Ba=commit%3Bh=fdd41c995d1f719e92c6f083e780226114762f05
- https://lists.debian.org/debian-lts-announce/2018/04/msg00021.html
- https://usn.ubuntu.com/3883-1/
- https://www.debian.org/security/2018/dsa-4178
- https://www.libreoffice.org/about-us/security/advisories/cve-2018-10119/
- https://access.redhat.com/errata/RHSA-2018:3054
Get alerted when CVE-2018-10119 or the next vulnerability affects your stack