What’s Vulnerable › Vulnerabilities
CVE-2018-10120
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-16 · updated 2026-06-17
- Weakness: CWE-129
Description
The SwCTBWrapper::Read function in sw/source/filter/ww8/ww8toolbar.cxx in LibreOffice before 5.4.6.1 and 6.x before 6.0.2.1 does not validate a customizations index, which allows remote attackers to cause a denial of service (heap-based buffer overflow with write access) or possibly have unspecified other impact via a crafted document that contains a certain Microsoft Word record.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Debian Linux: 7.0, 8.0, 9.0
- The Document Foundation LibreOffice: before 5.4.6.1; from 6.0.0 before 6.0.2.1 — fixed in 5.4.6.1, 6.0.2.1
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 5.4.6.1, 6.0.2.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:3054
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=6173
- https://gerrit.libreoffice.org/#/c/49486/
- https://gerrit.libreoffice.org/#/c/49499/
- https://gerrit.libreoffice.org/#/c/49500/
- https://gerrit.libreoffice.org/gitweb?p=core.git%3Ba=commit%3Bh=017fcc2fcd00af17a97bd5463d89662404f57667
- https://lists.debian.org/debian-lts-announce/2018/04/msg00021.html
- https://usn.ubuntu.com/3883-1/
- https://www.debian.org/security/2018/dsa-4178
- https://www.libreoffice.org/about-us/security/advisories/cve-2018-10120/
- https://access.redhat.com/errata/RHSA-2018:3054
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=6173
Get alerted when CVE-2018-10120 or the next vulnerability affects your stack