What’s Vulnerable › Vulnerabilities
CVE-2018-10309
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Cookie Consent plugin before 1.8 for WordPress mishandles number fields, leading to XSS.
Affected products
- Responsive Cookie Consent Project Responsive Cookie Consent: before 1.8 — fixed in 1.8
How to fix
Upgrade to a fixed version: Responsive Cookie Consent Project Responsive Cookie Consent 1.8. Check the vendor advisory for mitigations.
References
- https://gist.github.com/B0UG/f0cfb356e23be3cd6ebea69566d6100a
- https://wordpress.org/plugins/responsive-cookie-consent/#developers
- https://wpvulndb.com/vulnerabilities/9067
- https://www.exploit-db.com/exploits/44563/
- https://gist.github.com/B0UG/f0cfb356e23be3cd6ebea69566d6100a
- https://wordpress.org/plugins/responsive-cookie-consent/#developers
- https://wpvulndb.com/vulnerabilities/9067
- https://www.exploit-db.com/exploits/44563/
Get alerted when CVE-2018-10309 or the next vulnerability affects your stack