What’s Vulnerable › Vulnerabilities
CVE-2018-10310
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
A persistent cross-site scripting vulnerability has been identified in the web interface of the Catapult UK Cookie Consent plugin before 2.3.10 for WordPress that allows the execution of arbitrary HTML/script code in the context of a victim's browser.
Affected products
- Catapultthemes Cookie Consent: before 2.3.10 — fixed in 2.3.10
How to fix
Upgrade to a fixed version: Catapultthemes Cookie Consent 2.3.10. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/147333/WordPress-UK-Cookie-Consent-2.3.9-Cross-Site-Scripting.html
- https://gist.github.com/B0UG/9732614abccaf2893c352d14c822d07b
- https://wordpress.org/plugins/uk-cookie-consent/#developers
- https://www.exploit-db.com/exploits/44503/
- http://packetstormsecurity.com/files/147333/WordPress-UK-Cookie-Consent-2.3.9-Cross-Site-Scripting.html
- https://gist.github.com/B0UG/9732614abccaf2893c352d14c822d07b
- https://wordpress.org/plugins/uk-cookie-consent/#developers
- https://www.exploit-db.com/exploits/44503/
Get alerted when CVE-2018-10310 or the next vulnerability affects your stack