What’s Vulnerable › Vulnerabilities
CVE-2018-10377
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-17 · updated 2026-06-17
- Weakness: CWE-295
Description
PortSwigger Burp Suite before 1.7.34 has Improper Certificate Validation of the Collaborator server certificate, which might allow man-in-the-middle attackers to obtain interaction data.
Affected products
- Tenable Burp Suite Community Edition: before 1.7.34 — fixed in 1.7.34
How to fix
Upgrade to a fixed version: Tenable Burp Suite Community Edition 1.7.34. Check the vendor advisory for mitigations.
References
- http://releases.portswigger.net/2018/06/1734.html
- https://hackerone.com/reports/337680
- https://integritylabs.io/advisories/cve-2018-10377
- http://releases.portswigger.net/2018/06/1734.html
- https://hackerone.com/reports/337680
- https://integritylabs.io/advisories/cve-2018-10377
Get alerted when CVE-2018-10377 or the next vulnerability affects your stack