What’s Vulnerable › Vulnerabilities
CVE-2018-1050
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-13 · updated 2026-06-17
- Weakness: CWE-476
Description
All versions of Samba from 4.0.0 onwards are vulnerable to a denial of service attack when the RPC spoolss service is configured to be run as an external daemon. Missing input sanitization checks on some of the input parameters to spoolss RPC calls could cause the print spooler service to crash.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Samba: from 3.6.0 before 4.5.16; from 4.6.0 before 4.6.14; from 4.7.0 before 4.7.6 — fixed in 4.5.16, 4.6.14, 4.7.6
How to fix
Upgrade to a fixed version: Samba 4.5.16, 4.6.14, 4.7.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103387
- http://www.securitytracker.com/id/1040493
- https://access.redhat.com/errata/RHSA-2018:1860
- https://access.redhat.com/errata/RHSA-2018:1883
- https://access.redhat.com/errata/RHSA-2018:2612
- https://access.redhat.com/errata/RHSA-2018:2613
- https://access.redhat.com/errata/RHSA-2018:3056
- https://bugzilla.redhat.com/show_bug.cgi?id=1538771
- https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0
- https://lists.debian.org/debian-lts-announce/2018/03/msg00024.html
- https://lists.debian.org/debian-lts-announce/2019/04/msg00013.html
- https://security.gentoo.org/glsa/201805-07
Get alerted when CVE-2018-1050 or the next vulnerability affects your stack