What’s Vulnerable › Vulnerabilities
CVE-2018-10500
- Severity: high (CVSS 7.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-24 · updated 2026-06-17
- Weakness: CWE-284
Description
This vulnerability allows local attackers to escalate privileges on vulnerable installations of Samsung Galaxy Apps Fixed in version 6.4.0.15. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the handling of push messages. The issue lies in the ability to start an activity with controlled arguments. An attacker can leverage this vulnerability to escalate privileges to resources normally protected from the application. Was ZDI-CAN-5331.
Affected products
- Samsung Galaxy Apps: before 6.4.0.15 — fixed in 6.4.0.15
How to fix
Upgrade to a fixed version: Samsung Galaxy Apps 6.4.0.15. Check the vendor advisory for mitigations.
References
- https://zerodayinitiative.com/advisories/ZDI-18-559
- https://zerodayinitiative.com/advisories/ZDI-18-559
Get alerted when CVE-2018-10500 or the next vulnerability affects your stack