What’s Vulnerable › Vulnerabilities
CVE-2018-10545
- Severity: medium (CVSS 4.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-29 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in PHP before 5.6.35, 7.0.x before 7.0.29, 7.1.x before 7.1.16, and 7.2.x before 7.2.4. Dumpable FPM child processes allow bypassing opcache access controls because fpm_unix.c makes a PR_SET_DUMPABLE prctl call, allowing one user (in a multiuser environment) to obtain sensitive information from the process memory of a second user's PHP applications by running gcore on the PID of the PHP-FPM worker process.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- NetApp Storage Automation Store: all versions
- PHP: before 5.6.35; from 7.0.0 before 7.0.29; from 7.1.0 before 7.1.16; from 7.2.0 before 7.2.4 — fixed in 5.6.35, 7.0.29, 7.1.16, 7.2.4
How to fix
Upgrade to a fixed version: PHP 5.6.35, 7.0.29, 7.1.16, 7.2.4. Check the vendor advisory for mitigations.
References
- http://php.net/ChangeLog-5.php
- http://php.net/ChangeLog-7.php
- http://www.securityfocus.com/bid/104022
- https://access.redhat.com/errata/RHSA-2019:2519
- https://bugs.php.net/bug.php?id=75605
- https://lists.debian.org/debian-lts-announce/2018/05/msg00004.html
- https://lists.debian.org/debian-lts-announce/2018/06/msg00005.html
- https://security.gentoo.org/glsa/201812-01
- https://security.netapp.com/advisory/ntap-20180607-0003/
- https://usn.ubuntu.com/3646-1/
- https://usn.ubuntu.com/3646-2/
- https://www.debian.org/security/2018/dsa-4240
Get alerted when CVE-2018-10545 or the next vulnerability affects your stack