What’s Vulnerable › Vulnerabilities
CVE-2018-10548
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-29 · updated 2026-06-17
- Weakness: CWE-476
Description
An issue was discovered in PHP before 5.6.36, 7.0.x before 7.0.30, 7.1.x before 7.1.17, and 7.2.x before 7.2.5. ext/ldap/ldap.c allows remote LDAP servers to cause a denial of service (NULL pointer dereference and application crash) because of mishandling of the ldap_get_dn return value.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- NetApp Storage Automation Store: all versions
- PHP: before 5.6.36; from 7.0.0 before 7.0.30; from 7.1.0 before 7.1.17; from 7.2.0 before 7.2.5 — fixed in 5.6.36, 7.0.30, 7.1.17, 7.2.5
How to fix
Upgrade to a fixed version: PHP 5.6.36, 7.0.30, 7.1.17, 7.2.5. Check the vendor advisory for mitigations.
References
- http://php.net/ChangeLog-5.php
- http://php.net/ChangeLog-7.php
- http://www.securityfocus.com/bid/104019
- http://www.securitytracker.com/id/1040807
- https://access.redhat.com/errata/RHSA-2019:2519
- https://bugs.php.net/bug.php?id=76248
- https://lists.debian.org/debian-lts-announce/2018/05/msg00004.html
- https://lists.debian.org/debian-lts-announce/2018/06/msg00005.html
- https://security.gentoo.org/glsa/201812-01
- https://security.netapp.com/advisory/ntap-20180607-0003/
- https://usn.ubuntu.com/3646-1/
- https://usn.ubuntu.com/3646-2/
Get alerted when CVE-2018-10548 or the next vulnerability affects your stack