What’s Vulnerable › Vulnerabilities
CVE-2018-1056
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-122
Description
An out-of-bounds heap buffer read flaw was found in the way advancecomp before 2.1-2018/02 handled processing of ZIP files. An attacker could potentially use this flaw to crash the advzip utility by tricking it into processing crafted ZIP files.
Affected products
- advancecomp: before 2.1 — fixed in 2.1
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: advancecomp 2.1. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=889270
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1056
- https://lists.debian.org/debian-lts-announce/2018/02/msg00016.html
- https://lists.debian.org/debian-lts-announce/2019/03/msg00004.html
- https://lists.debian.org/debian-lts-announce/2021/12/msg00034.html
- https://sourceforge.net/p/advancemame/bugs/259/
- https://usn.ubuntu.com/3570-1/
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=889270
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1056
- https://lists.debian.org/debian-lts-announce/2018/02/msg00016.html
- https://lists.debian.org/debian-lts-announce/2019/03/msg00004.html
- https://lists.debian.org/debian-lts-announce/2021/12/msg00034.html
Get alerted when CVE-2018-1056 or the next vulnerability affects your stack