What’s Vulnerable › Vulnerabilities
CVE-2018-1057
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-13 · updated 2026-06-17
- Weakness: CWE-863
Description
On a Samba 4 AD DC the LDAP server in all versions of Samba from 4.0.0 onwards incorrectly validates permissions to modify passwords over LDAP allowing authenticated users to change any other users' passwords, including administrative users and privileged service accounts (eg Domain Controllers).
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 8.0
- Samba: from 4.0.0 before 4.5.16; from 4.6.0 before 4.6.14; from 4.7.0 before 4.7.6 — fixed in 4.5.16, 4.6.14, 4.7.6
How to fix
Upgrade to a fixed version: Samba 4.5.16, 4.6.14, 4.7.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103382
- http://www.securitytracker.com/id/1040494
- https://bugzilla.redhat.com/show_bug.cgi?id=1553553
- https://lists.debian.org/debian-lts-announce/2019/04/msg00013.html
- https://security.gentoo.org/glsa/201805-07
- https://security.netapp.com/advisory/ntap-20180313-0001/
- https://usn.ubuntu.com/3595-1/
- https://www.debian.org/security/2018/dsa-4135
- https://www.samba.org/samba/security/CVE-2018-1057.html
- https://www.synology.com/support/security/Synology_SA_18_08
- http://www.securityfocus.com/bid/103382
- http://www.securitytracker.com/id/1040494
Get alerted when CVE-2018-1057 or the next vulnerability affects your stack