What’s Vulnerable › Vulnerabilities
CVE-2018-1059
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-24 · updated 2026-06-17
- Weakness: CWE-200
Description
The DPDK vhost-user interface does not check to verify that all the requested guest physical range is mapped and contiguous when performing Guest Physical Addresses to Host Virtual Addresses translations. This may lead to a malicious guest exposing vhost-user backend process memory. All versions before 18.02.1 are vulnerable.
Affected products
- Canonical Ubuntu Linux: 17.10, 18.04
- DPDK Data Plane Development Kit: before 18.02.1 — fixed in 18.02.1
- Red Hat Ceph Storage: 3.0
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Fast Datapath: 7.0
- Openshift: 3.0
- OpenStack: 8, 9, 10, 11, 12
- RedHat Virtualization: 4.0, 4.1
- RedHat Virtualization Manager: 4.1
How to fix
Upgrade to a fixed version: DPDK Data Plane Development Kit 18.02.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:1267
- https://access.redhat.com/errata/RHSA-2018:2038
- https://access.redhat.com/errata/RHSA-2018:2102
- https://access.redhat.com/errata/RHSA-2018:2524
- https://access.redhat.com/security/cve/cve-2018-1059
- https://bugzilla.redhat.com/show_bug.cgi?id=1544298
- https://usn.ubuntu.com/3642-1/
- https://usn.ubuntu.com/3642-2/
- https://access.redhat.com/errata/RHSA-2018:1267
- https://access.redhat.com/errata/RHSA-2018:2038
- https://access.redhat.com/errata/RHSA-2018:2102
- https://access.redhat.com/errata/RHSA-2018:2524
Get alerted when CVE-2018-1059 or the next vulnerability affects your stack