What’s Vulnerable › Vulnerabilities
CVE-2018-10612
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-29 · updated 2026-06-17
- Weakness: CWE-284
Description
In 3S-Smart Software Solutions GmbH CODESYS Control V3 products prior to version 3.5.14.0, user access management and communication encryption is not enabled by default, which could allow an attacker access to the device and sensitive information, including user credentials.
Affected products
- CODESYS Control for BeagleBone SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control For Empc-A/Imx6 Sl: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for IOT2000 SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for Linux SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for PFC100 SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for PFC200 SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control for Raspberry Pi SL: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control RTE (SL): from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control Runtime Toolkit: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Control Win (SL): from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS Development System V3: from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
- CODESYS HMI (SL): from 3.0 before 3.5.14.0 — fixed in 3.5.14.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 3.5.14.0; CODESYS Control For Empc-A/Imx6 Sl 3.5.14.0; CODESYS Control for IOT2000 SL 3.5.14.0; CODESYS Control for Linux SL 3.5.14.0; CODESYS Control for PFC100 SL 3.5.14.0; CODESYS Control for PFC200 SL 3.5.14.0; CODESYS Control for Raspberry Pi SL 3.5.14.0; CODESYS Control RTE (SL) 3.5.14.0; CODESYS Control Runtime Toolkit 3.5.14.0; CODESYS Control Win (SL) 3.5.14.0; CODESYS Development System V3 3.5.14.0; CODESYS HMI (SL) 3.5.14.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106248
- https://ics-cert.us-cert.gov/advisories/ICSA-18-352-03
- http://www.securityfocus.com/bid/106248
- https://ics-cert.us-cert.gov/advisories/ICSA-18-352-03
Get alerted when CVE-2018-10612 or the next vulnerability affects your stack