What’s Vulnerable › Vulnerabilities
CVE-2018-10627
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-24 · updated 2026-06-17
- Weakness: CWE-200
Description
Echelon SmartServer 1 all versions, SmartServer 2 all versions prior to release 4.11.007, i.LON 100 all versions, and i.LON 600 all versions. An attacker can use the SOAP API to retrieve and change sensitive configuration items such as the usernames and passwords for the Web and FTP servers. This vulnerability does not affect the i.LON 600 product.
Affected products
- Echelon I.Lon 100 Firmware: all versions
- Echelon Smartserver 1 Firmware: all versions
- Echelon Smartserver 2 Firmware: before 4.11.007 — fixed in 4.11.007
How to fix
Upgrade to a fixed version: Echelon Smartserver 2 Firmware 4.11.007. Check the vendor advisory for mitigations.
References
- https://ics-cert.us-cert.gov/advisories/ICSA-18-200-03
- https://ics-cert.us-cert.gov/advisories/ICSA-18-200-03
Get alerted when CVE-2018-10627 or the next vulnerability affects your stack