What’s Vulnerable › Vulnerabilities
CVE-2018-10657
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-02 · updated 2026-06-17
- Weakness: CWE-20
Description
Matrix Synapse before 0.28.1 is prone to a denial of service flaw where malicious events injected with depth = 2^63 - 1 render rooms unusable, related to federation/federation_base.py and handlers/message.py, as exploited in the wild in April 2018.
Affected products
- matrix-org synapse: before 0.28.1 — fixed in 0.28.1
How to fix
Upgrade to a fixed version: matrix-org synapse 0.28.1. Check the vendor advisory for mitigations.
References
- https://github.com/matrix-org/synapse/commit/33f469ba19586bbafa0cf2c7d7c35463bdab87eb
- https://matrix.org/blog/2018/05/01/security-update-synapse-0-28-1/
- https://github.com/matrix-org/synapse/commit/33f469ba19586bbafa0cf2c7d7c35463bdab87eb
- https://matrix.org/blog/2018/05/01/security-update-synapse-0-28-1/
Get alerted when CVE-2018-10657 or the next vulnerability affects your stack