What’s Vulnerable › Vulnerabilities
CVE-2018-1067
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-21 · updated 2026-06-17
- Weakness: CWE-113
Description
In Undertow before versions 7.1.2.CR1, 7.1.2.GA it was found that the fix for CVE-2016-4993 was incomplete and Undertow web server is vulnerable to the injection of arbitrary HTTP headers, and also response splitting, due to insufficient sanitization and validation of user input before the input is used as part of an HTTP header value.
Affected products
- Red Hat JBoss EAP: 7.1
- Red Hat undertow: before 1.4.25; from 2.0.0 before 2.0.5 — fixed in 1.4.25, 2.0.5
- RedHat Virtualization Host: 4.0
How to fix
Upgrade to a fixed version: Red Hat undertow 1.4.25, 2.0.5. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:1247
- https://access.redhat.com/errata/RHSA-2018:1248
- https://access.redhat.com/errata/RHSA-2018:1249
- https://access.redhat.com/errata/RHSA-2018:1251
- https://access.redhat.com/errata/RHSA-2018:2643
- https://access.redhat.com/errata/RHSA-2019:0877
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1067
- https://access.redhat.com/errata/RHSA-2018:1247
- https://access.redhat.com/errata/RHSA-2018:1248
- https://access.redhat.com/errata/RHSA-2018:1249
- https://access.redhat.com/errata/RHSA-2018:1251
- https://access.redhat.com/errata/RHSA-2018:2643
Get alerted when CVE-2018-1067 or the next vulnerability affects your stack