What’s Vulnerable › Vulnerabilities
CVE-2018-1070
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-12 · updated 2026-06-17
- Weakness: CWE-20
Description
routing before version 3.10 is vulnerable to an improper input validation of the Openshift Routing configuration which can cause an entire shard to be brought down. A malicious user can use this vulnerability to cause a Denial of Service attack for other users of the router shard.
Affected products
- Red Hat OpenShift Container Platform 4.18: before 3.10 — fixed in 3.10
How to fix
Upgrade to a fixed version: Red Hat OpenShift Container Platform 4.18 3.10. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:2013
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1070
- https://access.redhat.com/errata/RHSA-2018:2013
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1070
Get alerted when CVE-2018-1070 or the next vulnerability affects your stack