What’s Vulnerable › Vulnerabilities
CVE-2018-10811
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-19 · updated 2026-06-17
- Weakness: CWE-909
Description
strongSwan 5.6.0 and older allows Remote Denial of Service because of Missing Initialization of a Variable.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 28
- strongSwan: from 5.0.1 before 5.6.3 — fixed in 5.6.3
How to fix
Upgrade to a fixed version: strongSwan 5.6.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00047.html
- https://download.strongswan.org/security/CVE-2018-10811/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UBO6ZQKLB5RY3TV7MXADFTQKXA2LUEIL/
- https://security.gentoo.org/glsa/201811-16
- https://usn.ubuntu.com/3771-1/
- https://www.debian.org/security/2018/dsa-4229
- https://www.strongswan.org/blog/2018/05/28/strongswan-vulnerability-%28cve-2018-10811%29.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00047.html
Get alerted when CVE-2018-10811 or the next vulnerability affects your stack