What’s Vulnerable › Vulnerabilities
CVE-2018-1084
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-12 · updated 2026-06-17
- Weakness: CWE-190
Description
corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04
- Corosync: from 2.3.0 before 2.4.4 — fixed in 2.4.4
- Debian Linux: 9.0
- RedHat Enterprise Linux Server: 7.0
How to fix
Upgrade to a fixed version: Corosync 2.4.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103758
- https://access.redhat.com/errata/RHSA-2018:1169
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1084
- https://security.gentoo.org/glsa/202107-01
- https://usn.ubuntu.com/4000-1/
- https://www.debian.org/security/2018/dsa-4174
- http://www.securityfocus.com/bid/103758
- https://access.redhat.com/errata/RHSA-2018:1169
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1084
- https://security.gentoo.org/glsa/202107-01
- https://usn.ubuntu.com/4000-1/
- https://www.debian.org/security/2018/dsa-4174
Get alerted when CVE-2018-1084 or the next vulnerability affects your stack