What’s Vulnerable › Vulnerabilities
CVE-2018-10843
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-02 · updated 2026-06-17
- Weakness: CWE-20
Description
source-to-image component of Openshift Container Platform before versions atomic-openshift 3.7.53, atomic-openshift 3.9.31 is vulnerable to a privilege escalation which allows the assemble script to run as the root user in a non-privileged container. An attacker can use this flaw to open network connections, and possibly other actions, on the host which are normally only available to a root user.
Affected products
- Red Hat OpenShift Container Platform 4.18: before 3.7.53; 3.9, 3.9.31 — fixed in 3.7.53
How to fix
Upgrade to a fixed version: Red Hat OpenShift Container Platform 4.18 3.7.53. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:2013
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10843
- https://access.redhat.com/errata/RHSA-2018:2013
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10843
Get alerted when CVE-2018-10843 or the next vulnerability affects your stack