What’s Vulnerable › Vulnerabilities
CVE-2018-10847
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-30 · updated 2026-06-17
- Weakness: CWE-592
Description
prosody before versions 0.10.2, 0.9.14 is vulnerable to an Authentication Bypass. Prosody did not verify that the virtual host associated with a user session remained the same across stream restarts. A user may authenticate to XMPP host A and migrate their authenticated session to XMPP host B of the same Prosody instance.
Affected products
- Prosody: before 0.9.14; 0.10.0, 0.10.1 — fixed in 0.9.14
How to fix
Upgrade to a fixed version: Prosody 0.9.14. Check the vendor advisory for mitigations.
References
- https://blog.prosody.im/prosody-0-10-2-security-release/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10847
- https://issues.prosody.im/1147
- https://prosody.im/security/advisory_20180531/
- https://www.debian.org/security/2018/dsa-4216
- https://blog.prosody.im/prosody-0-10-2-security-release/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10847
- https://issues.prosody.im/1147
- https://prosody.im/security/advisory_20180531/
- https://www.debian.org/security/2018/dsa-4216
Get alerted when CVE-2018-10847 or the next vulnerability affects your stack