What’s Vulnerable › Vulnerabilities
CVE-2018-10850
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-13 · updated 2026-06-17
- Weakness: CWE-362
Description
389-ds-base before versions 1.4.0.10, 1.3.8.3 is vulnerable to a race condition in the way 389-ds-base handles persistent search, resulting in a crash if the server is under load. An anonymous attacker could use this flaw to trigger a denial of service.
Affected products
- Debian Linux: 8.0
- Red Hat, Inc. 389-ds-base: before 1.4.0.10 — fixed in 1.4.0.10
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Red Hat, Inc. 389-ds-base 1.4.0.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00033.html
- https://access.redhat.com/errata/RHSA-2018:2757
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10850
- https://lists.debian.org/debian-lts-announce/2018/07/msg00018.html
- https://pagure.io/389-ds-base/c/8f04487f99a
- https://pagure.io/389-ds-base/issue/49768
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00033.html
- https://access.redhat.com/errata/RHSA-2018:2757
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10850
- https://lists.debian.org/debian-lts-announce/2018/07/msg00018.html
- https://pagure.io/389-ds-base/c/8f04487f99a
- https://pagure.io/389-ds-base/issue/49768
Get alerted when CVE-2018-10850 or the next vulnerability affects your stack